$re = '/\_(\d+)|\^(\d{1})|\_\{(\d+)\}|\^\{(\d+)\}/';
$str = '\\int_5^{3}100x-100=10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);