#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\s*<div class="results-count">[^\n]*\n\K.*?(?=\n\s*<div class="clear"></div>)"
Local $sString = "RUBBISH" & @CRLF & _
"RUBBISH" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
" <div class="span9">" & @CRLF & _
" <div class="results-count">AAA</div>" & @CRLF & _
" <div class="AA">" & @CRLF & _
" <div class="A"><a href="/TEST">BBB</a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="BB"><span>CCC</span><br/><a href="/TEST1" class="B">DDD</a>" & @CRLF & _
" <div></div><span>EEE</span><br/><img src="TEST2" title="C"/><a href="/TEST3" class="D">FFF</a>," & @CRLF & _
" <a href="/TEST4" class="E">GGG</a>" & @CRLF & _
" <div class="clear"></div><a href="/TEST5" class="details">Details</a>" & @CRLF & _
" </div>" & @CRLF & _
" <pre>HHH</pre>" & @CRLF & _
" <div class="clear"></div>" & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" <div class="span9">" & @CRLF & _
" <div class="results-count">AAA</div>" & @CRLF & _
" <div class="AA">" & @CRLF & _
" <div class="A"><a href="/TEST">BBB</a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="BB"><span>CCC</span><br/><a href="/TEST1" class="B">DDD</a>" & @CRLF & _
" <div></div><span>EEE</span><br/><img src="TEST2" title="C"/><a href="/TEST3" class="D">FFF</a>," & @CRLF & _
" <a href="/TEST4" class="E">GGG</a>" & @CRLF & _
" <div class="clear"></div><a href="/TEST5" class="details">Details</a>" & @CRLF & _
" </div>" & @CRLF & _
" <pre>HHH</pre>" & @CRLF & _
" <div class="clear"></div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"RUBBISH" & @CRLF & _
"RUBBISH" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="span9">" & @CRLF & _
" <div class="results-count">AAA</div>" & @CRLF & _
" <div class="AA">" & @CRLF & _
" <div class="A"><a href="/TEST">BBB</a>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="BB"><span>CCC</span><br/><a href="/TEST1" class="B">DDD</a>" & @CRLF & _
" <div></div><span>EEE</span><br/><img src="TEST2" title="C"/><a href="/TEST3" class="D">FFF</a>," & @CRLF & _
" <a href="/TEST4" class="E">GGG</a>" & @CRLF & _
" <div class="clear"></div><a href="/TEST5" class="details">Details</a>" & @CRLF & _
" </div>" & @CRLF & _
" <pre>HHH</pre>" & @CRLF & _
" <div class="clear"></div>" & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" ."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")