re = /\s*<div class="results-count">[^\n]*\n\K.*?(?=\n\s*<div class="clear"><\/div>)/
str = 'RUBBISH
RUBBISH
.
.
.
<div class="span9">
<div class="results-count">AAA</div>
<div class="AA">
<div class="A"><a href="/TEST">BBB</a>
</div>
<div class="BB"><span>CCC</span><br/><a href="/TEST1" class="B">DDD</a>
<div></div><span>EEE</span><br/><img src="TEST2" title="C"/><a href="/TEST3" class="D">FFF</a>,
<a href="/TEST4" class="E">GGG</a>
<div class="clear"></div><a href="/TEST5" class="details">Details</a>
</div>
<pre>HHH</pre>
<div class="clear"></div>
.
.
.
<div class="span9">
<div class="results-count">AAA</div>
<div class="AA">
<div class="A"><a href="/TEST">BBB</a>
</div>
<div class="BB"><span>CCC</span><br/><a href="/TEST1" class="B">DDD</a>
<div></div><span>EEE</span><br/><img src="TEST2" title="C"/><a href="/TEST3" class="D">FFF</a>,
<a href="/TEST4" class="E">GGG</a>
<div class="clear"></div><a href="/TEST5" class="details">Details</a>
</div>
<pre>HHH</pre>
<div class="clear"></div>
RUBBISH
RUBBISH
<div class="span9">
<div class="results-count">AAA</div>
<div class="AA">
<div class="A"><a href="/TEST">BBB</a>
</div>
<div class="BB"><span>CCC</span><br/><a href="/TEST1" class="B">DDD</a>
<div></div><span>EEE</span><br/><img src="TEST2" title="C"/><a href="/TEST3" class="D">FFF</a>,
<a href="/TEST4" class="E">GGG</a>
<div class="clear"></div><a href="/TEST5" class="details">Details</a>
</div>
<pre>HHH</pre>
<div class="clear"></div>
.
.
.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end