using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*<div class=""results-count"">[^\n]*\n\K.*?(?=\n\s*<div class=""clear""></div>)";
string input = @"RUBBISH
RUBBISH
.
.
.
<div class=""span9"">
<div class=""results-count"">AAA</div>
<div class=""AA"">
<div class=""A""><a href=""/TEST"">BBB</a>
</div>
<div class=""BB""><span>CCC</span><br/><a href=""/TEST1"" class=""B"">DDD</a>
<div></div><span>EEE</span><br/><img src=""TEST2"" title=""C""/><a href=""/TEST3"" class=""D"">FFF</a>,
<a href=""/TEST4"" class=""E"">GGG</a>
<div class=""clear""></div><a href=""/TEST5"" class=""details"">Details</a>
</div>
<pre>HHH</pre>
<div class=""clear""></div>
.
.
.
<div class=""span9"">
<div class=""results-count"">AAA</div>
<div class=""AA"">
<div class=""A""><a href=""/TEST"">BBB</a>
</div>
<div class=""BB""><span>CCC</span><br/><a href=""/TEST1"" class=""B"">DDD</a>
<div></div><span>EEE</span><br/><img src=""TEST2"" title=""C""/><a href=""/TEST3"" class=""D"">FFF</a>,
<a href=""/TEST4"" class=""E"">GGG</a>
<div class=""clear""></div><a href=""/TEST5"" class=""details"">Details</a>
</div>
<pre>HHH</pre>
<div class=""clear""></div>
RUBBISH
RUBBISH
<div class=""span9"">
<div class=""results-count"">AAA</div>
<div class=""AA"">
<div class=""A""><a href=""/TEST"">BBB</a>
</div>
<div class=""BB""><span>CCC</span><br/><a href=""/TEST1"" class=""B"">DDD</a>
<div></div><span>EEE</span><br/><img src=""TEST2"" title=""C""/><a href=""/TEST3"" class=""D"">FFF</a>,
<a href=""/TEST4"" class=""E"">GGG</a>
<div class=""clear""></div><a href=""/TEST5"" class=""details"">Details</a>
</div>
<pre>HHH</pre>
<div class=""clear""></div>
.
.
.";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}