import re
regex = re.compile(r"\s*<div class=\"results-count\">[^\n]*\n\K.*?(?=\n\s*<div class=\"clear\"></div>)", flags=re.DOTALL)
test_str = ("RUBBISH\n"
"RUBBISH\n"
".\n"
".\n"
".\n"
" <div class=\"span9\">\n"
" <div class=\"results-count\">AAA</div>\n"
" <div class=\"AA\">\n"
" <div class=\"A\"><a href=\"/TEST\">BBB</a>\n"
" </div>\n"
" <div class=\"BB\"><span>CCC</span><br/><a href=\"/TEST1\" class=\"B\">DDD</a>\n"
" <div></div><span>EEE</span><br/><img src=\"TEST2\" title=\"C\"/><a href=\"/TEST3\" class=\"D\">FFF</a>,\n"
" <a href=\"/TEST4\" class=\"E\">GGG</a>\n"
" <div class=\"clear\"></div><a href=\"/TEST5\" class=\"details\">Details</a>\n"
" </div>\n"
" <pre>HHH</pre>\n"
" <div class=\"clear\"></div>\n"
" .\n"
" .\n"
" .\n"
" <div class=\"span9\">\n"
" <div class=\"results-count\">AAA</div>\n"
" <div class=\"AA\">\n"
" <div class=\"A\"><a href=\"/TEST\">BBB</a>\n"
" </div>\n"
" <div class=\"BB\"><span>CCC</span><br/><a href=\"/TEST1\" class=\"B\">DDD</a>\n"
" <div></div><span>EEE</span><br/><img src=\"TEST2\" title=\"C\"/><a href=\"/TEST3\" class=\"D\">FFF</a>,\n"
" <a href=\"/TEST4\" class=\"E\">GGG</a>\n"
" <div class=\"clear\"></div><a href=\"/TEST5\" class=\"details\">Details</a>\n"
" </div>\n"
" <pre>HHH</pre>\n"
" <div class=\"clear\"></div>\n\n\n"
"RUBBISH\n"
"RUBBISH\n\n\n"
" <div class=\"span9\">\n"
" <div class=\"results-count\">AAA</div>\n"
" <div class=\"AA\">\n"
" <div class=\"A\"><a href=\"/TEST\">BBB</a>\n"
" </div>\n"
" <div class=\"BB\"><span>CCC</span><br/><a href=\"/TEST1\" class=\"B\">DDD</a>\n"
" <div></div><span>EEE</span><br/><img src=\"TEST2\" title=\"C\"/><a href=\"/TEST3\" class=\"D\">FFF</a>,\n"
" <a href=\"/TEST4\" class=\"E\">GGG</a>\n"
" <div class=\"clear\"></div><a href=\"/TEST5\" class=\"details\">Details</a>\n"
" </div>\n"
" <pre>HHH</pre>\n"
" <div class=\"clear\"></div>\n"
" .\n"
" .\n"
" .")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")