import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*<div class=\"results-count\">[^\\n]*\\n\\K.*?(?=\\n\\s*<div class=\"clear\"></div>)";
final String string = "RUBBISH\n"
+ "RUBBISH\n"
+ ".\n"
+ ".\n"
+ ".\n"
+ " <div class=\"span9\">\n"
+ " <div class=\"results-count\">AAA</div>\n"
+ " <div class=\"AA\">\n"
+ " <div class=\"A\"><a href=\"/TEST\">BBB</a>\n"
+ " </div>\n"
+ " <div class=\"BB\"><span>CCC</span><br/><a href=\"/TEST1\" class=\"B\">DDD</a>\n"
+ " <div></div><span>EEE</span><br/><img src=\"TEST2\" title=\"C\"/><a href=\"/TEST3\" class=\"D\">FFF</a>,\n"
+ " <a href=\"/TEST4\" class=\"E\">GGG</a>\n"
+ " <div class=\"clear\"></div><a href=\"/TEST5\" class=\"details\">Details</a>\n"
+ " </div>\n"
+ " <pre>HHH</pre>\n"
+ " <div class=\"clear\"></div>\n"
+ " .\n"
+ " .\n"
+ " .\n"
+ " <div class=\"span9\">\n"
+ " <div class=\"results-count\">AAA</div>\n"
+ " <div class=\"AA\">\n"
+ " <div class=\"A\"><a href=\"/TEST\">BBB</a>\n"
+ " </div>\n"
+ " <div class=\"BB\"><span>CCC</span><br/><a href=\"/TEST1\" class=\"B\">DDD</a>\n"
+ " <div></div><span>EEE</span><br/><img src=\"TEST2\" title=\"C\"/><a href=\"/TEST3\" class=\"D\">FFF</a>,\n"
+ " <a href=\"/TEST4\" class=\"E\">GGG</a>\n"
+ " <div class=\"clear\"></div><a href=\"/TEST5\" class=\"details\">Details</a>\n"
+ " </div>\n"
+ " <pre>HHH</pre>\n"
+ " <div class=\"clear\"></div>\n\n\n"
+ "RUBBISH\n"
+ "RUBBISH\n\n\n"
+ " <div class=\"span9\">\n"
+ " <div class=\"results-count\">AAA</div>\n"
+ " <div class=\"AA\">\n"
+ " <div class=\"A\"><a href=\"/TEST\">BBB</a>\n"
+ " </div>\n"
+ " <div class=\"BB\"><span>CCC</span><br/><a href=\"/TEST1\" class=\"B\">DDD</a>\n"
+ " <div></div><span>EEE</span><br/><img src=\"TEST2\" title=\"C\"/><a href=\"/TEST3\" class=\"D\">FFF</a>,\n"
+ " <a href=\"/TEST4\" class=\"E\">GGG</a>\n"
+ " <div class=\"clear\"></div><a href=\"/TEST5\" class=\"details\">Details</a>\n"
+ " </div>\n"
+ " <pre>HHH</pre>\n"
+ " <div class=\"clear\"></div>\n"
+ " .\n"
+ " .\n"
+ " .";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}