using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"logs\\(.*?\.log)";
string input = @"input {
file {
path => ""C:\tools\apache-tomcat-8.0.32\logs\abcd_access_log.2016-03-15.log""
start_position => beginning
}
}
input {
file {
path => ""C:\tools\apache-tomcat-8.0.32\logs\efgh_access_log.2016-02-16.log""
start_position => beginning
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}