// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"logs\\(.*?\.log)").unwrap();
let string = "input {
file {
path => \"C:\\tools\\apache-tomcat-8.0.32\\logs\\abcd_access_log.2016-03-15.log\"
start_position => beginning
}
}
input {
file {
path => \"C:\\tools\\apache-tomcat-8.0.32\\logs\\efgh_access_log.2016-02-16.log\"
start_position => beginning
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}