import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "logs\\\\(.*?\\.log)";
final String string = "input { \n"
+ " file {\n"
+ " path => \"C:\\tools\\apache-tomcat-8.0.32\\logs\\abcd_access_log.2016-03-15.log\"\n"
+ " start_position => beginning\n"
+ " } \n"
+ "}\n\n"
+ "input { \n"
+ " file {\n"
+ " path => \"C:\\tools\\apache-tomcat-8.0.32\\logs\\efgh_access_log.2016-02-16.log\"\n"
+ " start_position => beginning\n"
+ " } \n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}