re = /logs\\(.*?\.log)/
str = 'input {
file {
path => "C:\\tools\\apache-tomcat-8.0.32\\logs\\abcd_access_log.2016-03-15.log"
start_position => beginning
}
}
input {
file {
path => "C:\\tools\\apache-tomcat-8.0.32\\logs\\efgh_access_log.2016-02-16.log"
start_position => beginning
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end