using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\dA-F]{2}(?:[:\-][\dA-F]{2}){5}";
string input = @"00:11:22:33:44:55
aa-bb-de-ee-ff-45
fdfdsfdfdfdf";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}