package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\dA-F]{2}(?:[:\-][\dA-F]{2}){5}`)
var str = `00:11:22:33:44:55
aa-bb-de-ee-ff-45
fdfdsfdfdfdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}