$re = '/[\dA-F]{2}(?:[:\-][\dA-F]{2}){5}/i';
$str = '00:11:22:33:44:55
aa-bb-de-ee-ff-45
fdfdsfdfdfdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);