re = /[\dA-F]{2}(?:[:\-][\dA-F]{2}){5}/i
str = '00:11:22:33:44:55
aa-bb-de-ee-ff-45
fdfdsfdfdfdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end