use strict;
my $str = '00:11:22:33:44:55
aa-bb-de-ee-ff-45
fdfdsfdfdfdf';
my $regex = qr/[\dA-F]{2}(?:[:\-][\dA-F]{2}){5}/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}