#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "/page_[\s\S]+?(/|\z)"
Local $sString = "http://my-domain.com/search/page_2/order_asc" & @CRLF & _
"http://my-domain.com/search/page_5/order_asc" & @CRLF & _
"http://my-domain.com/search/order_asc/page_5"
Local $sSubst = "/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)