const regex = new RegExp('/page_[\\s\\S]+?(/|\\z)', 'g')
const str = `http://my-domain.com/search/page_2/order_asc
http://my-domain.com/search/page_5/order_asc
http://my-domain.com/search/order_asc/page_5`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);