use strict;
my $str = 'http://my-domain.com/search/page_2/order_asc
http://my-domain.com/search/page_5/order_asc
http://my-domain.com/search/order_asc/page_5';
my $regex = qr~/page_[\s\S]+?(/|\z)~p;
my $subst = '/';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";