import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/page_[\\s\\S]+?(/|\\z)";
final String string = "http://my-domain.com/search/page_2/order_asc\n"
+ "http://my-domain.com/search/page_5/order_asc\n"
+ "http://my-domain.com/search/order_asc/page_5";
final String subst = "/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}