re = /\/page_[\s\S]+?(\/|\z)/
str = 'http://my-domain.com/search/page_2/order_asc
http://my-domain.com/search/page_5/order_asc
http://my-domain.com/search/order_asc/page_5'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result