const regex = /^(?=the|i|in|there|this|with|on|we|that|of).*$|^(?=.*(?:the|i|in|there|this|with|on|we|that|of)$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=the|i|in|there|this|with|on|we|that|of).*$|^(?=.*(?:the|i|in|there|this|with|on|we|that|of)$).*$', 'gm')
const str = `the european union
would like to
would like
of the european
the european parliament
the member states`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);