$re = '/^(?=the|i|in|there|this|with|on|we|that|of).*$|^(?=.*(?:the|i|in|there|this|with|on|we|that|of)$).*$/m';
$str = 'the european union
would like to
would like
of the european
the european parliament
the member states';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;