re = /^(?=the|i|in|there|this|with|on|we|that|of).*$|^(?=.*(?:the|i|in|there|this|with|on|we|that|of)$).*$/m
str = 'the european union
would like to
would like
of the european
the european parliament
the member states'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result