import re
regex = re.compile(r"^(?=the|i|in|there|this|with|on|we|that|of).*$|^(?=.*(?:the|i|in|there|this|with|on|we|that|of)$).*$", flags=re.MULTILINE)
test_str = ("the european union\n"
"would like to\n"
"would like\n"
"of the european\n"
"the european parliament\n"
"the member states")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)