#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!foo\b|foobar\b)(?!.*;foo;)(?!.*;foobar;).*(?<!\bfoo)(?<!\bfoobar)$"
Local $sString = "baz;quz - regex should match the line" & @CRLF & _
"baz;foo;qux - regex should not match the line" & @CRLF & _
"foobar;baz - regex should not match the line" & @CRLF & _
"foobaz;bar - regex should match the line" & @CRLF & _
"baz;qux;foobar" & @CRLF & _
";baz;bar.foo;qux" & @CRLF & _
"baz;foo;quz" & @CRLF & _
";baz.foo.qux;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")