re = /^(?!foo\b|foobar\b)(?!.*;foo;)(?!.*;foobar;).*(?<!\bfoo)(?<!\bfoobar)$/m
str = 'baz;quz - regex should match the line
baz;foo;qux - regex should not match the line
foobar;baz - regex should not match the line
foobaz;bar - regex should match the line
baz;qux;foobar
;baz;bar.foo;qux
baz;foo;quz
;baz.foo.qux;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end