using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!foo\b|foobar\b)(?!.*;foo;)(?!.*;foobar;).*(?<!\bfoo)(?<!\bfoobar)$";
string input = @"baz;quz - regex should match the line
baz;foo;qux - regex should not match the line
foobar;baz - regex should not match the line
foobaz;bar - regex should match the line
baz;qux;foobar
;baz;bar.foo;qux
baz;foo;quz
;baz.foo.qux;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}