$re = '/^(?!foo\b|foobar\b)(?!.*;foo;)(?!.*;foobar;).*(?<!\bfoo)(?<!\bfoobar)$/m';
$str = 'baz;quz - regex should match the line
baz;foo;qux - regex should not match the line
foobar;baz - regex should not match the line
foobaz;bar - regex should match the line
baz;qux;foobar
;baz;bar.foo;qux
baz;foo;quz
;baz.foo.qux;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);