use strict;
my $str = 'baz;quz - regex should match the line
baz;foo;qux - regex should not match the line
foobar;baz - regex should not match the line
foobaz;bar - regex should match the line
baz;qux;foobar
;baz;bar.foo;qux
baz;foo;quz
;baz.foo.qux;';
my $regex = qr/^(?!foo\b|foobar\b)(?!.*;foo;)(?!.*;foobar;).*(?<!\bfoo)(?<!\bfoobar)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}