#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".(?:src="(http:\/\/website\.bla\.com\/Live.+?)".+?)|Status.*\s(Sld|Rtr)"
Local $sString = "<div ng-class="{" & @CRLF & _
" 'active': active" & @CRLF & _
" }" class="item text-center ng-isolate-scope" ng-transclude="" ng-repeat="slide in slides" active="slide.active">" & @CRLF & _
" <img class="image-circle ng-scope" ng-src="http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg" src="http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg">" & @CRLF & _
" </div><!-- end ngRepeat: slide in slides --><div ng-class="{" & @CRLF & _
" 'active': active" & @CRLF & _
" }" class="item text-center ng-isolate-scope" ng-transclude="" ng-repeat="slide in slides" active="slide.active">" & @CRLF & _
" <img class="image-circle ng-scope" ng-src="http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg" src="http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg">" & @CRLF & _
" </div><!-- end ngRepeat: slide in slides --><div ng-class="{" & @CRLF & _
" 'active': active" & @CRLF & _
" }" class="item text-center ng-isolate-scope" ng-transclude="" ng-repeat="slide in slides" active="slide.active">" & @CRLF & _
" <img class="image-circle ng-scope" ng-src="http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg" src="http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg">" & @CRLF & _
" </div><!-- end ngRepeat: slide in slides -->" & @CRLF & _
" </div>" & @CRLF & _
"<b class="ng-binding">Status:</b> Sld"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")