// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".(?:src="(http:\/\/website\.bla\.com\/Live.+?)".+?)|Status.*\s(Sld|Rtr)"#).unwrap();
let string = "<div ng-class=\"{
'active': active
}\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">
<img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg\" src=\"http://website.bla.com/Live/photos/FULL/18/134/W3764134_18.jpg\">
</div><!-- end ngRepeat: slide in slides --><div ng-class=\"{
'active': active
}\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">
<img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg\" src=\"http://website.bla.com/Live/photos/FULL/19/134/W3764134_19.jpg\">
</div><!-- end ngRepeat: slide in slides --><div ng-class=\"{
'active': active
}\" class=\"item text-center ng-isolate-scope\" ng-transclude=\"\" ng-repeat=\"slide in slides\" active=\"slide.active\">
<img class=\"image-circle ng-scope\" ng-src=\"http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg\" src=\"http://website.bla.com/Live/photos/FULL/20/134/W3764134_20.jpg\">
</div><!-- end ngRepeat: slide in slides -->
</div>
<b class=\"ng-binding\">Status:</b> Sld";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}