use strict;
my $str = 'omglolwtfbbq
lllllll';
my $regex = qr/(?=l)|(?<=l)/mp;
my $subst = '!';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";