$re = '/(?=l)|(?<=l)/m';
$str = 'omglolwtfbbq
lllllll';
$subst = "!";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;