import Foundation
let pattern = #"(?=l)|(?<=l)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
omglolwtfbbq
lllllll
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"!"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)