# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\d])[0-9]{4,6}([^\d])/$1$2/gim;t' <<< "ABC1234DEFGH
A123BCDEFGH
ABCDE1234567FG
ABC1234DEFGH
ABCDEF123456
12534"