// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)([^\d])[0-9]{4,6}([^\d])").unwrap();
let string = "ABC1234DEFGH
A123BCDEFGH
ABCDE1234567FG
ABC1234DEFGH
ABCDEF123456
12534";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}