import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\d])[0-9]{4,6}([^\\d])";
final String string = "ABC1234DEFGH \n"
+ "A123BCDEFGH\n"
+ "ABCDE1234567FG\n"
+ "ABC1234DEFGH\n"
+ "ABCDEF123456\n"
+ "12534";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}