$re = '/([^\d])[0-9]{4,6}([^\d])/im';
$str = 'ABC1234DEFGH
A123BCDEFGH
ABCDE1234567FG
ABC1234DEFGH
ABCDEF123456
12534';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;