import re
regex = re.compile(r"([^\d])[0-9]{4,6}([^\d])", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("ABC1234DEFGH \n"
"A123BCDEFGH\n"
"ABCDE1234567FG\n"
"ABC1234DEFGH\n"
"ABCDEF123456\n"
"12534")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)