use strict;
my $str = 'x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
May15 > TRUE
May15, > TRUE
May15 + > FALSE
May15 x > FALSE
TRADED; Mar15 x May15, 5 MW Base 121,50 TL';
my $regex = qr/[x+-]\s*(?:may15|may)\K|(?:may15|may)\s*[x+-]\K|(?:may15|may)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}