re = /[x+-]\s*(?:may15|may)\K|(?:may15|may)\s*[x+-]\K|(?:may15|may)/im
str = 'x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
May15 > TRUE
May15, > TRUE
May15 + > FALSE
May15 x > FALSE
TRADED; Mar15 x May15, 5 MW Base 121,50 TL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end