import re
regex = re.compile(r"[x+-]\s*(?:may15|may)\K|(?:may15|may)\s*[x+-]\K|(?:may15|may)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("x May15 > WRONG\n"
"- May15 > WRONG\n"
"+ May15 > WRONG\n"
"xMay15 > WRONG\n"
"-May15 > WRONG\n"
"+May15 > WRONG\n"
"May15 > TRUE\n"
"May15, > TRUE\n"
"May15 + > FALSE\n"
"May15 x > FALSE\n\n"
"TRADED; Mar15 x May15, 5 MW Base 121,50 TL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")