$re = '/[x+-]\s*(?:may15|may)\K|(?:may15|may)\s*[x+-]\K|(?:may15|may)/im';
$str = 'x May15 > WRONG
- May15 > WRONG
+ May15 > WRONG
xMay15 > WRONG
-May15 > WRONG
+May15 > WRONG
May15 > TRUE
May15, > TRUE
May15 + > FALSE
May15 x > FALSE
TRADED; Mar15 x May15, 5 MW Base 121,50 TL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);