#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:[^_]*_){5}[^_]*).*$"
Local $sString = "HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.html" & @CRLF & _
"HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.swf" & @CRLF & _
"HTZ_2015_CS_SS5_cncenter_1500x1000_160K_w1020.jpg"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)