import re
regex = re.compile(r"^((?:[^_]*_){5}[^_]*).*$", flags=re.MULTILINE)
test_str = ("HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.html\n"
"HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.swf\n"
"HTZ_2015_CS_SS5_cncenter_1500x1000_160K_w1020.jpg")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)