const regex = /^((?:[^_]*_){5}[^_]*).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:[^_]*_){5}[^_]*).*$', 'gm')
const str = `HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.html
HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.swf
HTZ_2015_CS_SS5_cncenter_1500x1000_160K_w1020.jpg`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);