re = /^((?:[^_]*_){5}[^_]*).*$/m
str = 'HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.html
HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.swf
HTZ_2015_CS_SS5_cncenter_1500x1000_160K_w1020.jpg'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result