const regex = /^[^\n]*\?[^\n]*(?:\n|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\n]*\\?[^\\n]*(?:\\n|$)', 'gim')
const str = `"Diva" was the winning song of the Eurovision Song Contest 1998.
Who will win Eurovision Song Contest 2015?
Eurovision Song Contest Statistics:
Who will win Eurovision 2015?`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);