# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\n]*\?[^\n]*(?:\n|$)"
test_str = ("\"Diva\" was the winning song of the Eurovision Song Contest 1998.\n"
"Who will win Eurovision Song Contest 2015?\n"
"Eurovision Song Contest Statistics:\n"
"Who will win Eurovision 2015?")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.