#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=Java[=:])(?:(')[^']*(')|\S+)"
Local $sString = " Java='f fyf ufu', Java=123"
Local $sSubst = "$1*****$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)